3a Product and API Failure
Incident Report for Ikonik Digital Agency
Update
We are continuing to investigate this issue.
Posted Aug 14, 2022 - 23:57 CDT
Investigating
We are currently investigating a major outage.
Posted Mar 01, 2022 - 23:56 CST
This incident affects: Dashboards (3a Lite Solutions).